Career Sites Live Issue

Incident Report for TalosATS

Postmortem

We received notification that the indexes for Careers Page Builder (External and Internal) were failing to run. This resulted in vacancies not being updated. This includes:

  • New job posts 
  • Expiring job posts
  • Any job post updates reposted to Careers Page Builder sites

Our developers manually updated the indexes with all changes to vacancies within 30 minutes of being made aware of the issue. The indexes started to run successfully.

We are implementing protocols to improve performance that will help to prevent indexes from failing in future.

Thank you for your patience during this time.

Posted Aug 08, 2025 - 10:30 UTC

Resolved

This incident has now been resolved.
Posted Aug 08, 2025 - 09:36 UTC

Monitoring

We are monitoring the fix that has been implemented to ensure careers pages are stable.
Posted Aug 08, 2025 - 09:34 UTC

Update

We are monitoring the fix that has been implemented to ensure careers pages are stable.
Posted Aug 08, 2025 - 09:33 UTC

Identified

We have identified the issue and have implemented a fix.
Posted Aug 08, 2025 - 09:31 UTC

Update

We have now manually updated all Careers Page Builder sites with new vacancies, and these are now displaying as expected. We are continuing to investigate the cause of the issue. Thank you for your patience.
Posted Aug 08, 2025 - 09:26 UTC

Investigating

We are investigating a live issue that is affecting Careers Page Builder sites, preventing sites from updating with new vacancies. Our team is actively investigating the issue and working to restore services as quickly as possible. Thank you for your patience.
Posted Aug 08, 2025 - 08:58 UTC
This incident affected: Talos360 Careers Pages (Careers Page Builder API).